No categories assigned

How to Install Third-Party Code Plugins From the Unreal Engine Marketplace

Prerequisites

  • Install the Epic Games Launcher and the Unreal Engine by following the instructions here.
    • Make sure to install the version of Unreal Engine that matches the version of Unreal Editor for Aximmetry. To find out which version you need, launch Unreal Editor for Aximmetry and click Help / About Unreal Editor. Only the first two components of the version number is relevant which looks like 4.25.
    • Optional: in Step 3 of Installing Unreal Engine click Options and disable all components except "Engine Source". This saves several GBs of disk space.
  • Install Visual Studio 2019 by following the instructions here.
    • In Step 2 - Download Visual Studio: choose Visual Studio 2019 Community edition.
    • In Step 4 - Choose workloads: select "Game Development with C++"
    • Ignore Step 5-8

Installing Plugins

  • Open the Epic Games Launcher and install the desired plugins from the Marketplace. Certain plugins require some additional steps. See instructions listed below.
  • Open Unreal Editor for Aximmetry. In the Aximmetry menu, click Install Plugins. The first installation will take quite a long time, however subsequent installations should be significantly faster.
  • Enable the plugins you want and restart the editor if needed.

Additional instructions for installing plugins

Most plugins can be installed by following the simple steps above, however certain plugins require some additional steps. If you want to use the plugins listed below, please complete these instructions before clicking Install Plugins in Unreal Editor for Aximmetry.

V-Ray For Unreal

  • In the Current Installation Parameters step click Customize.
  • Change Unreal Engine plugins location to [installation path]\Engine\Plugins\Marketplace. ([installation path] should point to the original Unreal Engine installation - do not change it to Unreal Editor for Aximmetry.)
  • Make sure the Install Chaos Cloud Client option is checked.
  • Finish the rest of the installation as usual.

Megascans

  • Install the plugin for the original Unreal Engine by following the instructons here.
  • The plugin can be installed either via the Quixel Bridge application or by manually downloading and unzipping it into the engine plugins directory. Both methods work fine, choose what you are more comfortable with.
  • Launch Unreal Editor for Aximmetry and start the plugin installation as described above.

Substance

Note: This plugin is known to crash the Unreal Editor in certain cases. This is a bug in the plugin so it happens with the vanilla Unreal Editor as well. The crash happens when certain meshes are sent to the Substance Painter. It seems to be caused by a material name collision. This can be worked around by moving the mesh asset to a different directory before clicking "Send to Substance Painter".

Character Creator & iClone Auto Setup

  • Follow the official tutorial through steps 1 - 8.
  • In step 9, copy the Content directory into your project as instructed. Do not copy the Plugins directory into your project. Instead, copy it to the Engine\Plugins\Marketplace directory of the original Unreal Engine.
  • Launch Unreal Editor for Aximmetry and install the plugins as described above.

MVN Live Link

  • Before cooking the project, go to Edit / Project Settings / Maps & Modes / Game Instance and set Game Instance Class to LiveLinkGameInstance.
  • Close the Unreal Editor before loading the project in Aximmetry because the MVN Live Link can only handle a single active connection.

NVIDIA DLSS

Follow the official installation guide that's included with the downloaded plugin (DLSS_Plugin_Installation_Guide.pdf).

  • In step 5, copy the plugin to Epic Games\UE_4.26\Engine\Plugins\Marketplace instead of Epic Games\UE_4.26\Engine\Plugins\Runtime\Nvidia.
  • In step 6, launch Unreal Editor for Aximmetry and install the plugins as described above.

iTween

  • Download the plugin from the link found here. Make sure to download the version that was compiled for the engine version that you are using (e.g. "compiled for 4.26" if you have UE 4.26 installed).
  • Extract the downloaded archive to Epic Games\UE_4.xx\Engine\Plugins\Marketplace\iTween.
  • Launch Unreal Editor for Aximmetry and install the plugins as described above.